Security Affairs
CVE-2026-58868: Critical Android Bug Could Let Attackers Run Remote Code|U.S. CISA adds WordPress flaw to its Known Exploited Vulnerabilities catalog|Binance Hack: How Fake Job Interviews and AI Abuse Led to a $6.34 Billion Attack|Synology Warns of Ransomware Attacks Targeting NAS Devices Running Outdated DSM Versions|Inside XCPE, the botnet that turned 1.3M set-top boxes into proxy servers|NIS2 Makes Board Members Personally Liable for Access Control Decisions|Apple’s spyware notifications reach the Bundestag: what the BSI says to do now|VOLTA, the infostealer that asks an AI which victims are worth the effort|New wave of fridge cyberattacks hits European supermarkets, this time in Belgium, Luxembourg, Sweden and Estonia|Hackers Send Fake Nuclear Threat Alerts to Ukrainian and Russian Citizens|Chainalysis Investigates Security Incident Involving AI-Driven Attack Techniques|FBI Blames North Korea for $6 Billion Binance Crypto Theft|CVE-2026-58868: Critical Android Bug Could Let Attackers Run Remote Code|U.S. CISA adds WordPress flaw to its Known Exploited Vulnerabilities catalog|Binance Hack: How Fake Job Interviews and AI Abuse Led to a $6.34 Billion Attack|Synology Warns of Ransomware Attacks Targeting NAS Devices Running Outdated DSM Versions|Inside XCPE, the botnet that turned 1.3M set-top boxes into proxy servers|NIS2 Makes Board Members Personally Liable for Access Control Decisions|Apple’s spyware notifications reach the Bundestag: what the BSI says to do now|VOLTA, the infostealer that asks an AI which victims are worth the effort|New wave of fridge cyberattacks hits European supermarkets, this time in Belgium, Luxembourg, Sweden and Estonia|Hackers Send Fake Nuclear Threat Alerts to Ukrainian and Russian Citizens|Chainalysis Investigates Security Incident Involving AI-Driven Attack Techniques|FBI Blames North Korea for $6 Billion Binance Crypto Theft|
Advertisement

Ad Placeholder

Full Width × 90

Breaking News

Drupal addresses two XSS flaws by updating the CKEditor

Drupal developers released security updates for versions 8.8.x and 8.7.x that fix two XSS vulnerabilities affecting the CKEditor library. The Drupal development team has released security updates for versions 8.8.x and 8.7.x that address two XSS vulnerabilities that affect the CKEditor library. CKEditor is the far superior successor of FCKeditor, it is a popular, highly […]

Drupal PHP code execution

Drupal developers released security updates for versions 8.8.x and 8.7.x that fix two XSS vulnerabilities affecting the CKEditor library.

The Drupal development team has released security updates for versions 8.8.x and 8.7.x that address two XSS vulnerabilities that affect the CKEditor library.

CKEditor is the far superior successor of FCKeditor, it is a popular, highly configurable open-source WYSIWYG editor.

Drupal uses CKEditor, it has updated to version 4.14, which addressed two cross-site scripting (XSS) vulnerabilities.

“The Drupal project uses the third-party library CKEditor, which has released a security improvement that is needed to protect some Drupal configurations.” reads the advisory published by Drupal.

“Vulnerabilities are possible if Drupal is configured to use the WYSIWYG CKEditor for your site’s users. An attacker that can create or edit content may be able to exploit this Cross Site Scripting (XSS) vulnerability to target users with access to the WYSIWYG CKEditor, and this may include site admins with privileged access.”

Both issues have been rated as a moderately critical severity, they received a risk score of 13/25.

The latest versions of Drupal, versions 8.8.4 or 8.7.12, include CKEditor version 4.14 that fix both issues.

Drupal 8 versions prior to 8.7.x have reached end-of-life and will not receive security updates, Drupal 7 is not affected by the issue, but it is recommended the use of CKEditor version 4.14 or higher.

The risk of exploitation of the flaws could be mitigated by disabling the CKEditor module.

According to the release note published by CKEditor 4.14 the flaws are not easy to exploit.

For example, one of the XSS flaws affects the HTML data processor, it could be exploited by tricking the victims into pasting malicious HTML code into the editor, either in WYSIWYG mode or source mode.

The other issue impacts a third-party plugin named WebSpellChecker Dialog plugin that is included in the Standard and Full presets of CKEditor 4. This issue could be exploited by an attacker that tricks the victim into switching CKEditor to source mode, pasting malicious code, switching back to WYSIWYG mode, and previewing the content on a page where the WebSpellChecker Dialog plugin files are available.

[adrotate banner=”9″] [adrotate banner=”12″]

Pierluigi Paganini

(SecurityAffairs – XSS, CKEditor)

[adrotate banner=”5″]

[adrotate banner=”13″]